"Invalid path to decrypt" error when using Decrypt Backup Data feature
May 12, 2025
Product Version
AhsayOBM: 9.1 or above
Operating System
Windows
Symptom
When attempting to restore using the Decrypt Backup Data feature in AhsayOBM, the error "Invalid path to decrypt" is displayed.
Cause
This error occurs when the specified path for the backup data is incorrect.
For example: D:\restore\1725378341650\blocks
Resolution
Ensure the backup data is located in the correct folder structure: %DiskDrive%\foldername\backupsetID\blocks
Example: D:\restore\1725397341650\blocks
- Click Decrypt.
- Enter the encryption key (if configured for the backup set).
- Select the files to restore/decrypt.
- Click Next.
- Choose the restore destination.
- Click Restore.