Article ID
2011
Last Reviewed Date
Product Version
AhsayACB / AhsayOBM: 7.17 or above
Operating System
All platforms
Symptom
When performing a backup of any type, the following warning message is received in the backup report:
No. | Type | Timestamp | Log |
---|---|---|---|
* | ... | ... | ... |
* | info | ... | Downloading server file list... Completed |
* | ... | ... | ... |
* | warn | YYYY/MM/DD hh:mm:ss |
Failed to save encrypted backup set encryption keys to server. Failed to get OutputStream of file: backup_id/settings/EncryptionKeys-YYYY-MM-DD.json.rgz, com.ahsay.afc.cloud.d: [ObsManager.newFolderIterator] Failed to list path: backup_id settings. |
* | ... | ... | ... |
Cause
The message suggests that the encryption key of the affected backup set cannot be saved to the backup server. A possible cause of this issue may be related to unstable connection between the AhsayOBM / AhsayACB clients and the AhsayCBS server.
Resolution
To resolve the issue, increase the upload timeout value for all affected client(s).
- Open the afc.opt file under the AhsayOBM / AhsayACB installation folder with a text editor.
- Add the following line to the end of the file:
com.ahsay.afc.cloud.cache.AbstractCachedCloudManager.readTimeout=180
afc.opt ... com.ahsay.ani.fsutil.FolderIterator.debug= com.ahsay.ani.fsutil.FolderIterator.javaOnly= com.ahsay.afc.cloud.cache.AbstractCachedCloudManager.readTimeout=180 The value 180 seconds is for example purposes only, you can adjust the timeout value to another value if required. - Save and exit from the text editor.
- Restart Ahsay Online Backup Manager Services / Ahsay A-Click Backup Services and client user interface.
- Perform the backup again to see if the problem persists.
Further increase the timeout value (e.g. to 300 seconds) if the problem persist. Alternatively, contact Ahsay support for further assistance.