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Symptom
When performing an Microsoft SQL database backup, the following warning message is displayed in the backup report:
No. | Type | Timestamp | Log |
---|---|---|---|
* | .... | .... | .... |
* | info | .... | Download valid index files from backup job "Current" to "temp_path\ backupset_id\index". |
* | warn | YYYY/MM/DD hh:mm:ss | Microsoft SQL Server not found! |
* | .... | .... | .... |
Cause
This issue can occur if the Windows account running the backup job is not found in the affected Microsoft SQL server's Security Logins, or if the account does not have the 'sysadmin' and 'public' Server Roles.
You can check by looking at the 'SQL ERRORLOG' file at:
${database_folder}\MSSQLog
Check if there may be errors such as the following: (e.g. the log entries around the time of the warning displayed in backup report):
YYYY-MM-DD hh:mm:ss.xx Logon Error: 18456, Severity: 14, State: 5.
YYYY-MM-DD hh:mm:ss.xx Logon Login failed for user 'COMPUTER_NAME\WINDOWS_ACCOUNT'. Reason: Could not find a login matching the name provided.
[CLIENT: ip_address]
YYYY-MM-DD hh:mm:ss.xx Logon Error, 18456, Severity: 14, State 5.
YYYY-MM-DD hh:mm:ss.xx Logon Login failed for user 'COMPUTER_NAME\WINDOWS_ACCOUNT'. Reason: Could not find a login matching the name provided.
[CLIENT: ]
The above message suggests that the Windows account running the backup job has not been assigned to the Microsoft SQL server's Security Login.
Resolution
To resolve the issue, perform the following steps:
- Open the SQL Server Management Studio
Under 'Object Explorer', select Security:
Select Logins, check if the Windows user that you are running the backup job with is there under Logins:
If the account is there, confirm if the public and sysadmin Server Roles have been assigned to the account (e.g. Right click, Properties, Server Roles).
- If the account is not there, add the account, then assign the public and sysadmin Server Role to it (e.g. Right click, New Login).