Skip to main content

Article ID

2050

Product Version

AhsayCBS: 8.1 - 8.7

Operating System

All platforms

Symptom

For backup data that were moved to retention un-intentionally, for example, when a removable backup source (e.g. faulty hard drive / USB external drive) was disconnected before a backup, the following warning message will be displayed:

No. Type Timestamp Log
warn
* warn YYYY/MM/DD hh:mm:ss Backup source "%backup_source%" does not exist!

Cause

Since the backup client cannot detect the backup source, all backup data are interpreted as deleted by the backup client, therefore, all backup data are moved to retention.

Resolution

Refer to the following steps to revert the index files (e.g. un-delete the data), so that the backup data will not be re-uploaded again when the backup source drive is reconnected.

The same steps can also be performed to revert the set of indexes to a healthy state (e.g. reverting to previous indexes from a successful backup when there's an index issue with the current set of indexes).
It is strongly recommended to temporarily suspend the backup user to ensure that no backup / restore is performed during the following steps.
  1. On the AhsayCBS web console, obtain the backup set ID of the affected backup set:

    • Under Backup / Restore, select Users, Groups & Policies

    • Select Backup User, and the corresponding backup user, then Backup Set.

    • Select the affected backup set under Manage Backup Set, the backup set ID is listed under General.

    step1

  2. From the backup destination (e.g. AhsayCBS), browse to the blocks folder where the backup data are stored in:

    %backup_destination%\%backupset_id%\blocks

    For example:
    For backup destination set to AhsayCBS

    C:\Program Files\AhsayCBS\user\username\1614747242788\blocks

    step2

    A separate folder is created for each backup job according to its start time (YYYY-MM-DD-hh-mm-ss), under the blocks folder. All files backed up by that job are stored in that particular order.
  3. Remove all index files in the blocks folder:

    %backup_destination%\%backupset_id%\blocks\index.db.*.cgz
    %backup_destination%\%backupset_id%\blocks\index.db.*.cgz

    step3

  4. Copy the index files from a previous backup job folder (the backup snapshot (YYYY-MM-DD-hh-mm-ss) which you would like to revert to back to the blocks folder.

    For example:
    To revert the backup snapshot to the backup on April 15, 2021 11:02:23, browse to:

    C:\Program Files\AhsayCBS\user\username\16147472427\blocks\2021-04-15-02-23\

    Copy

    C:\Program Files\AhsayCBS\user\username\1614747242788\blocks\2021-04-15-11-02-23\index.db.*.cgz
    
    C:\Program Files\AhsayCBS\user\username\1614747242788\blocks\2021-04-15-11-02-23\index.db.*.cgz

    To

    C:\Program Files\AhsayCBS\user\username\1614747242788\blocks\index.db.*.cgz
    C:\Program Files\AhsayCBS\user\username\1614747242788\blocks\index.db.*.cgz

    step4

    Once the backup snapshot is reverted, data backup by the latest backup (or sub-sequence backup after the snapshot which you have reverted to) will not be displayed in the restore menu.
  5. Ensure that the issue to the backup source drive is resolved, then perform another backup job afterward.