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Article ID

2060

Product Version

AhsayACB / AhsayOBM: 9.1 or above

Operating System

All Platforms

Symptom

When performing a backup job of any type on the AhsayOBM / AhsayACB client application, the following error message is received in the backup report:

No. Type Timestamp Log
info
* info YYYY/MM/DD hh:mm:ss ...
erro
* erro YYYY/MM/DD hh:mm:ss [SQLITE_CORRUPT] The database disk image is malformed (database disk image is malformed)

Cause

This issue can occur if there is a corrupted index file on the backup set.

There are many factors that could trigger a backup set index corruption:

  • The machine where the backup job is running was previously shutdown / rebooted when a backup job was still running.

  • Disk issue on the computer where the backup is performed.

  • Unstable network connection between the backup computer and network temp folder.

  • Backup client application crashed during a previous backup.

  • Backup client application encountered an out of memory of "Java Heap Size" error during a previous backup.

Resolution

To workaround this issue, try deleting the current index files from the temporary folder on the backup machine.

  1. Make sure there is no backup / restore job running.

  2. Browse to the folder:

    %temp_folder_path%\%backupSetID%\%destination_name%@%destinationID%\index\

    Example: C:\Users\ahsay\temp\1719374142445\OBS@1719374209145\index

  3. Delete the current index file.

  4. Perform a Data Integrity Check with rebuild index enabled.

  5. Perform a manual backup again.

If the SQLITE_CORRUPT error persists, contact Ahsay support representatives for further assistance.