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Article ID

2034

Product Version

AhsayACB / AhsayOBM: 8.1 - 8.7

Operating System

All platforms

Symptom

When performing a backup of any type, the following error message is received in the backup report:

No. Type Timestamp Log
info
* info YYYY/MM/DD hh:mm:ss Using Temporary Directory drive_letter\
path_with_special_
characters
\temp\backupset_id
\Local@
erro
* erro YYYY/MM/DD hh:mm:ss [d] Failed to initialize
RemoteBDB.Cloud. Error=
[BlockDBConfig.
readConfig] unknown default path for creating new journal file config: 0, caused by
[RuntimeException] [BlockDBConfig.
readConfig]
unknown default path for creating new journal file config: 0

Cause

This issue can occurs if the temporary index files in the backup set's temp folder are corrupted, or the index files in the backup destination are corrupted.

Resolution

To resolve the issue, perform the following steps:

  1. Ensure that the AhsayOBM / ACB client application are on the latest stable patch release. Patch instructions can be found by Clicking Here.

  2. First confirm if the issue maybe caused by corrupted index files in the temporary folder. Delete the index files in the backup set's temporary folder (e.g. E:\Users\user\temp\backupset_id\OBS@id\index\*).

    Bad Padding Exception

  3. Perform the backup again, the temporarily index files would be downloaded to the temp folder again. Continue to the next step only if the same backup error persists.

  4. If the problem persist, revert to an earlier set of index files (e.g. from the last successful backup).

    From the backup destination (e.g. AhsayCBS), browse to the "blocks" folder where the backup data are stored at:

    %backup_destination%\%backupset_id%\blocks

    For example:
    For backup destination set to AhsayCBS

    C:\UserHome\Username\1517279516004\blocks

    Bad Padding Exception

    A separate folder is created for each backup job according to its start time (YYYY-MM-DD-hh-mm-ss), under the "blocks" folder. All files backed up by that job are stored in that particular folder.
  5. Remove all index files (or move the files to another location) in the "blocks" folder:

    • %backup_destination%\%backupset_id%\blocks\index.b2b.*.cgz

    • %backup_destination%\%backupset_id%\blocks\index.xml.*.cgz

    • %backup_destination%\%backupset_id%\blocks\index-s0*.cgz

    Bad Padding Exception

  6. Copy the index files from a previous backup job folder (snapshot (YYYY-MM-DD-hh-mm-ss) that you would like to revert to (e.g. from the last successful backup)), back to the "blocks" folder.

    For example:
    To revert the indexes to the backup on March 29, 2019 11:48:26 browse to:

    Copy

    C:\UserHome\Username\1517279516004\blocks\2019-03-29-11-48-26\index.b2b.*.cgz
    C:\UserHome\Username\1517279516004\blocks\2019-03-29-11-48-26\index.xml.*.cgz
    C:\UserHome\Username\1517279516004\blocks\2019-03-29-11-48-26\index-s0*.cgz

    To

    C:\UserHome\Username\1517279516004\blocks\index.b2b.*.cgz
    C:\UserHome\Username\1517279516004\blocks\index.xml.*.cgz
    C:\UserHome\Username\1517279516004\blocks\index-s0*.cgz

    Bad Padding Exception

    After the index files are reverted, data backup by the latest backup job (or sub-sequence job after the snapshot which you have reverted to) will not be displayed in the restore menu.
  7. Perform the backup again to see if the problem persists.